Skip to content

[BUG] 最新版的WPS云文档打开报错 #2724

Description

@zhiwei1998

Please confirm the following

  • I have read and agree to AGPL-3.0 Section 15 .
    The program is provided "as is" without any warranties; you bear all risks of using it.

  • I have read and agree to AGPL-3.0 Section 16 .
    The copyright holders and distributors are not liable for any damages resulting from the use or inability to use the program.

  • I confirm my description is clear, polite, helps developers quickly locate the issue, and complies with community rules.

  • I have read the OpenList documentation.

  • I confirm there are no duplicate issues or discussions.

  • I confirm this is an OpenList issue, not caused by other reasons (such as network, dependencies, or operation).

  • I believe this issue must be handled by OpenList and not by a third party.

  • I confirm this issue is not fixed in the latest version.

  • I have not read these checkboxes and therefore I just ticked them all, Please close this issue.

OpenList Version (required)

v4.2.3

Storage Driver Used (required)

WPS云文档

Bug Description (required)

升级到最新的v4.2.3版本打开WPS云文档报错提示failed get objs: storage status: wps company id is empty, please check business account login: storage not init
,退回到v4.2.2就不会报错,可以正常打开

Logs (required)

[GIN] 2026/07/05 - 21:40:01 | 200 | 103.165µs | 10.10.2.229 | GET "/api/public/archive_extensions"
[GIN] 2026/07/05 - 21:40:01 | 200 | 238.326µs | 10.10.2.229 | GET "/api/me"
[GIN] 2026/07/05 - 21:40:01 | 200 | 693.184µs | 10.10.2.229 | POST "/api/fs/get"
[GIN] 2026/07/05 - 21:40:01 | 200 | 8.32ms | 10.10.2.229 | GET "/api/public/offline_download_tools"
ERRO[2026-07-05 21:40:01] fs/list: storage not init
storage status: wps company id is empty, please check business account login
ERRO[2026-07-05 21:40:01] failed list /WPS云文档/lanxiaoling: storage not init
storage status: wps company id is empty, please check business account login
failed get objs
[GIN] 2026/07/05 - 21:40:01 | 200 | 813.373µs | 10.10.2.229 | POST "/api/fs/list"
[GIN] 2026/07/05 - 21:40:18 | 200 | 1.4ms | 10.10.2.229 | GET "/WPS云文档/lanxiaoling"
[GIN] 2026/07/05 - 21:40:18 | 200 | 241.585µs | 10.10.2.229 | GET "/api/public/settings"
[GIN] 2026/07/05 - 21:40:18 | 200 | 147.396µs | 10.10.2.229 | GET "/api/public/archive_extensions"
[GIN] 2026/07/05 - 21:40:18 | 200 | 362.602µs | 10.10.2.229 | GET "/api/me"
[GIN] 2026/07/05 - 21:40:18 | 200 | 994.254µs | 10.10.2.229 | POST "/api/fs/get"
[GIN] 2026/07/05 - 21:40:18 | 200 | 8.15ms | 10.10.2.229 | GET "/api/public/offline_download_tools"
ERRO[2026-07-05 21:40:18] fs/list: storage not init
storage status: wps company id is empty, please check business account login
ERRO[2026-07-05 21:40:18] failed list /WPS云文档/lanxiaoling: storage not init
storage status: wps company id is empty, please check business account login
failed get objs
[GIN] 2026/07/05 - 21:40:18 | 200 | 1.19ms | 10.10.2.229 | POST "/api/fs/list"

Image

Configuration File Content (required)

{
"force": false,
"site_url": "http://xxxx.xx:5245",
"cdn": "",
"jwt_secret": "NwsdcDS4G3lX0N",
"token_expires_in": 120,
"database": {
"type": "mysql",
"host": "10.10.2.2",
"port": 3306,
"user": "xxxxx",
"password": "xxxxxx",
"name": "openlist",
"db_file": "/opt/openlist/data/data.db",
"table_prefix": "x_",
"ssl_mode": "",
"dsn": ""
},
"meilisearch": {
"host": "http://localhost:7700",
"api_key": "",
"index": "openlist"
},
"scheme": {
"address": "0.0.0.0",
"http_port": 5244,
"https_port": -1,
"force_https": false,
"cert_file": "",
"key_file": "",
"unix_file": "",
"unix_file_perm": "",
"enable_h2c": false,
"enable_h3": false
},
"temp_dir": "/mnt/usb/tmp/openlist",
"bleve_dir": "/opt/openlist/data/bleve",
"dist_dir": "",
"log": {
"enable": true,
"name": "/opt/openlist/data/log/log.log",
"max_size": 50,
"max_backups": 30,
"max_age": 28,
"compress": false,
"filter": {
"enable": false,
"filters": [
{
"cidr": "",
"path": "/ping",
"method": ""
},
{
"cidr": "",
"path": "",
"method": "HEAD"
},
{
"cidr": "",
"path": "/dav/",
"method": "PROPFIND"
}
]
}
},
"delayed_start": 0,
"auto_memory_limit": 4,
"min_free_memory": 0,
"max_block_limit": 0,
"max_connections": 0,
"max_concurrency": 64,
"tls_insecure_skip_verify": false,
"tasks": {
"download": {
"workers": 5,
"max_retry": 1,
"task_persistant": false
},
"transfer": {
"workers": 5,
"max_retry": 2,
"task_persistant": false
},
"upload": {
"workers": 5,
"max_retry": 0,
"task_persistant": false
},
"copy": {
"workers": 5,
"max_retry": 2,
"task_persistant": false
},
"move": {
"workers": 5,
"max_retry": 2,
"task_persistant": false
},
"decompress": {
"workers": 5,
"max_retry": 2,
"task_persistant": false
},
"decompress_upload": {
"workers": 5,
"max_retry": 2,
"task_persistant": false
},
"allow_retry_canceled": false
},
"cors": {
"allow_origins": [
""
],
"allow_methods": [
"
"
],
"allow_headers": [
"*"
]
},
"s3": {
"enable": false,
"port": 5246,
"ssl": false
},
"ftp": {
"enable": false,
"listen": ":5221",
"find_pasv_port_attempts": 50,
"active_transfer_port_non_20": false,
"idle_timeout": 900,
"connection_timeout": 30,
"disable_active_mode": false,
"default_transfer_binary": false,
"enable_active_conn_ip_check": true,
"enable_pasv_conn_ip_check": true
},
"sftp": {
"enable": false,
"listen": ":5222"
},
"mcp": {
"enable": false
},
"last_launched_version": "v4.2.3",
"proxy_address": ""

Image Image

Reproduction Link (optional)

内部使用的openlist没有公网的链接

AI Generated Content (optional)

No response

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    invalidInvalid Content/Cannot Reproduce

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions